Report Parameter Screen Scrollbar Disappears

When using a large number of parameters for a report, the report parameter screen will show up filling just about the whole browser screen and a scrollbar appears on the parameter screen. The problem we see is that the scrollbar will frequently disappear when entering parameters. Sometime the scroll position will randomly change with it. I just tried populating a date field as the last parameter for a report and lost the scrollbar and I am moved to the top of the parameter screen. It seems that refreshing the browse window will bring the scrollbar back.

This is proving to be very frustrating to some of our users for something that is out of the box and should work. I’m also on a short timeline so quick fixes / suggestions are welcome as well. Any suggestions on how I can improve the user experience here?


Could you please provide more information about your problem? Which version of the platform do you use? If it is possible, could you share the screenshot with the problem and some steps to reproduce?

We have been keeping the system up to date. Currently at 6.9.5. Windows 10 using Chrome browser.

Steps to reproduce:
1.Create a new Report (no new bands or data or anything, we are just going to create the parameter screen)
2. Create 10 parameters (named p1 - p10, all of them take a “List of entities” such as User).
3. Create an 11th parameter (named p11, parameter type: date).
4. Run the report to display the parameter screen (scrollbar appears on right as there are a lot of parameters)
5. Scroll to bottom and set the value to p11 using the date picker.
6. Scrollbar disappears, need to hit refresh in the browser to get the scrollbar back.

I’ve seen the scrollbar disappear after setting a parameter of type “List of entities” as well but not consistently.
Scrollbar has disappeared, can’t run the report or see other parameters.

Anything else you need?

Thank you.

Thank you for reporting the problem. We have created an issue.

As a workaround, you may change the style of the screen. First, you have to extend the platform theme.
Then in the halo-ext.scss file add the following:

.c-app-dialog-window > .popupContent .v-window-contents > .v-scrollable {
        max-height: 700px;

Pay attention, that in this case, all dialog windows will be using this style.