War deployment on different Tomcat port


I follwed the steps given in the topic above, but i keep getting a 404 error.

Steps: I changed the tomcat server port in the config file from 8080 to 80.
I changed my buildwar task :

task buildWar(type: CubaWarBuilding) {
    appHome = './app_home'
    singleWar = false
    includeContextXml = true
    includeJdbcDriver = true
    appProperties = [
        'cuba.automaticDatabaseUpdate': true,
        'cuba.webPort': 80,
        'cuba.connectionUrlList': 'http://localhost:80/frontdesk-core'

Created the war and core.war files. But i get 404 error.

Can anyone please help?




  1. Please show what folders and/or files do you have in the tomcat/webapps folder?
    This is essential to understand what web context names you’ll have to specify.

  2. Please review contents of tomcat log files, are there any startup errors?

Do you actually need to have two separate WAR files?
This is rarely needed. If you don’t have specific requirement for that, you can try with singleWar = true option.

Thanks Alex, i don’t need two seperate war files, so i corrected that. But i noticed another service running on port 80. When i stopped it and restarted tomcat, i could connect to my app. So problem is solved. Many thanks.