Unexpected Error using Oracle DB

Hi, I’m Thomas and I’m a beginner with Cuba Stusio. I worked in the past with RAD tools from Oracle and others.
I’m now looking for a new RAD tool since Oracle installation too complicate for a first pilot applicatio I want to build up for my customer.
So I anstalled Cuba and it looks quite easy to handle. After the first success with a little two entity app on HSQLDB. Then I tried to base on an Oracle DB with some defined tables (this is my goal) and defined some UIs on this. This was very simple and what I needed in a first step.
But running the application I get always the unexpected error (see screenshot) instead of the admin login.

So i started from the scratch and defined a new project based on HSQLDB without any entities and UI. Here it works.
Changing again to Oracle I get thie error again.
Anyone there who can help me?

grafik

Hey, Thomas!

See Oracle Database Specifics this.
Please, attach your app.log file

Hi Kirill,

thanks for the input. I still installed ojdbc6.jar, but where to stop gradle? in Command line I get this error,
meaning that gradle could not be found…
grafik

Hey!

See Gradle manual
In File Explorer right-click on the This PC (or Computer) icon, then click Properties -> Advanced System Settings -> Environmental Variables.
Under System Variables select Path, then click Edit. Add an entry for C:\Gradle\gradle-4.4.1\bin. Click OK to save.
Step 4. Verify your installation
Open a console (or a Windows command prompt) and run gradle -v to run gradle and display the version, e.g.:
$ gradle -v

or launch gradle --stop in project dir.

Hi,
ok, I attached the ojdbc6.jar to the lib, stopped the gradle and started studio again.
Now it works :slight_smile:

Thanks a lo, Kirill

1 Like

Have a nice day!
:slight_smile:

P.S. Mark the post as solved.