Unexpected error Please contact system administrator

If there is even a blank project, the admin login screen does not open.

Samples Projects Database error is not opening.

Before I open the project, is there anything I need to do without videos? Could you help ?

app.log (27.1 KB)

Hello @onrcrt44

What version of CUBA.platform do you use? Could you share your blank project where the problem can be reproduced?

Regards,
Daniil.

Version v.6.9.5, v.9.5, v.6.0, v.6.6
I tried many versions.
I open an empty project and I get an error.
This screen always comes up. It’s the same on every project.
Ads%C4%B1z

When opening Samples, such a window opens. When I start the project, the screen “Unexpected error Please contact system administrator” opens.
2

The error I get when I open another sample.

“ERROR com.haulmont.cuba.web.AppUI - Unable to init ui
java.lang.RuntimeException: Unable to login as anonymous!”

3

CUBA Studio shows you that database doesn’t matches with data model. It means that you should update or re-created a database to launch an app.

Have you tried to update a database?

The project does not open even when there is only one entity.

Hi,

It seems there is a problem with workshop sample and I’ve just fixed it.

As for the last application problem, could you please clarify what you are doing and what is wrong. Please provide details and context: what kind of entity do you create, what is the root (not the last, but first in the file) problem in log file and tell us how we can see the same.

My main problem is that when I open the Cuba Platform, create a new project and start without doing anything, the screen “Unexpected error Please contact system administrator” comes up.

Even if I add an Entity, this screen is coming up.

Why can not I access the login screen?

Most likely, this problem is caused by broken JAR file. Could you please stop Studio and remove ~/.gradle directory (usually in home directory of user)?

I solved the problem!
The problem is entirely about the windows language.
I was using the system language in Turkish.
When I turned to English, the problem was resolved.
This is a big problem for Turkish users. As soon as you wish to be solved …
Thank you for your help. Good work.Capture

2 Likes

Hi,

The problem is related to the EclipseLink ORM. We have an issue for the problem: https://github.com/cuba-platform/cuba/issues/566

Thank you,
Andrey