Unable to Open Project

Hey Guys,

Yesterday, I’ve downloaded the new studio (6.3.3) and when I tried to import the my project to it, the studio failed to open my project. I’ve attached an image with the error message it gives. Also, I have noticed that that the error message doesn’t disappear until I press on it. Can I implement something similar in my project using the showNotification or something else? Currently, I am working with the older version of studio version 6.3.0 and I have updated my platform to 6.3.5 and still doesn’t wanna open in the new studio, but works fine with the old one.

Thank you in advance

Cuba Error


Could you please attach the build.gradle file (rename it to build.txt)? Do not forget to delete your private information from the file.

I don’t know what you mean by private information from the file, but I’ve read the entire file and I didn’t find anything that I would mind showing to anyone.
Thanks for the reminder though

build.txt (4.7K)


At first, thank you for reporting the problem. We have created a YouTrack issue, see the link on the right.

There is a simple workaround: just quote the true in the appProperties in your buildWar task:

task buildWar(type: CubaWarBuilding) {
    appHome = './app_home'
    singleWar = false
    includeContextXml = true
    includeJdbcDriver = true
    appProperties = ['cuba.automaticDatabaseUpdate':'true']

And regarding the sensitive information. For example, database credentials might be presented in the createDb and updateDb tasks.

:ticket: See the following issue in our bug tracker: