Unable to edit Double

Hello everyone.
I’m meeting a problem even if I’m just using very standard bricks of the Cuba Platform

My goal is to manage teams capacity which is stored as a field typed as Double. When I want to edit the value, the field’s borders turn to red and I get a message “Alert Must be a Double” even the value I tried to save is 12.0 (I tried as well with 12,0; you know the weird French locale :wink:

This can be easily reproducible:

Create an Entity with a Double field (let’s call it capacity), update your DB, etc… and let’s create a standard screen with the Master-detail wizard. No changes, no additions, no tweaks; just keep what came out-of-the-box. Try it; you can create a new record but I bet you won’t be able to change the value of the capacity field.

Is there an explanation ? A workaround ?

Thanks for your support. Honestly I’m on this one for several hours and it makes me nuts.

Be safe. Good day.


Which version of the platform do you use? Do you use French locale in your project?



I’m using 2019.3 CS 193.7288.140

As far as I know I’m only using the default locale English | en (onto a French system)


I am asking about Platform framework version not Studio plugin)

oh, you mean 7.2.5 ?

Hi Olivier!
Could you please provide more information about your problem? Did you add any validations or number formats for this field? If it is possible, could you share a small project in order to help us investigate the problem?



Despite the issue still happens in my big project, I’m not able to reproduce it in a brand new project. As I found a workaround already (working with String and casting into Double) I propose to close this issue.
Thanks for your time anyway.
Have a great day.