Unable to customize Halo Theme

I have a wierd issue that has me banging my head against the screen all day.

I’m trying to extend the halo theme as per the instructions in the manual. The first thing I did was try extend the theme in the studio.

According to the instructions I should have been prompted to select which theme I wanted to extend. However, no option was presented and only “havana” was available. I clicked ok and the havana theme directory structure was created.
I already had an existing halo theme structure so I deleted that and renamed the havana to halo. Making the appropriate changes to file names, variables, etc.

The theme I’m trying to implement is based off of Materialize I’ve etracted all the appropriate source files manually from the this addon repo. https://github.com/appreciated/material

According to the docs https://doc.cuba-platform.com/manual-6.5/web_theme_extension.html

I should be able to modify the theme constants in halo-ext-defaults.scss however this does not work.
I’ve tried everything I can think of restarting, deleting the tomcat deploy directory, undeploying, cleaning in the studio and nothing works. I’ve even tried setting cuba.themeConfig = halo-theme.properties with no luck.

I think the issue is somehow, somewhere the CUBA thinks I’m trying to extend Havana instead of Halo and is getting confused. I was able to import a randomly named file “override.scss” which is in the same directory as halo-ext-defaults.scss the customizations were captured.


Could you, please, attach a sample project in which the problem is reproduced?

Additionally, you can take a look at this project material-theme-sandbox, in which the Material theme is used.


Hi Gleb

Thanks for the quick reply.

Not sure if something was cached or there is something else in the environment that is time dependent. But all of a sudden it is working as expected. Unfortunately, I’m forced to restart the server in studio after changes. I have a gradle watch task that is setup to redeploy if any of the styles change but that doesn’t seem to be working.
By the way my platform versions is platform-6.5.5. and Cuba Studio Server versions is 6.7.4.

If you feel that there is not much more information you can provide at this time with the given information please fee free to close this ticket.

Thanks again.