Task Outcome is not coming in flow outcome dropdown

Hi,

I want to create a workflow for our application. I followed the steps from https://doc.cuba-platform.com/bpm-6.2/qs_process_model_creation.html and created roles, task and outcomes for the task.
Now when I am creating a flow for that task, the outcomes are not coming in the dropdown list.

I followed the steps as bellow.

1.created two process roles for the model
i. Owner
ii. Supervisor

  1. Created Start event

  2. Created Standard form with the following two parameters
    i. procActorsVisible with true value
    ii. attachmentsVisible with true value

  3. Created a user task with the name as “Create” and assigned to the Owner role.

  4. Created two Task outcomes for "Create"
    i. Success
    ii. Fail with variable commentRequired = true

  5. After that add exclusive gateway node to the workspace and add two more elements
    i. Script task with Set “Fail” status name
    ii. User task with Validation name
    When selecting the Fail flow arrow and expanding the Flow outcome dropdown list from the properties panel it is not showing the
    task outcomes which i created during the creation of “Create” user task.

Please suggest me the way to fix this issue.

Thanks,
Subrat

Hi,
please, ensure that all arrows at the model are connected with model elements. If everything seems to be fine, then export the model using the “Export” button in the models browser and attach it here. I’ll take a look.

Hi,

I tried to export the workflow from model editor and i am unable to export as export button is not enabling means it always disable there.
I export process model from application and it came in json file. I have attached the file and screen shot of my model editor for your reference. Please find the attached file and suggest me how to fix the issue.

Case Approval.txt (6.3K)

mybpm

The arrow between the ‘Case create’ task and the exclusive gateway doesn’t connect items properly. It is not joined to the gateway (see the screenshot - I just moved the gateway there). Try to drop the end of the arrow to the gateway again and everything should work.

Screenshot_16

Thanks Max,

Thanks for your help, That was the issue and it solved my problem.