Sudden error in Assembling the project

I am suddenly getting this error from my project when I try to assemble or build the project. I didn’t make any changes in my add-ons though. It is looking for webjars. How can I fix it?

Could not determine the dependencies of task ':myProject-web-toolkit:buildWidgetSet'.
> Could not resolve all dependencies for configuration ':myProject-web:compile'.
   > Could not find any version that matches org.webjars.npm:mime-db:[1.52.0].
     Versions that do not match:
       - 1.51.0
       - 1.50.0
       - 1.49.0
       - 1.48.0
       - 1.47.0
       - + 21 more
     Searched in the following locations:
       - file:/Users/mak/.m2/repository/org/webjars/npm/mime-db/maven-metadata.xml
       - file:/Users/mak/.m2/repository/org/webjars/npm/mime-db/
     Required by:
         project :myProject-web > com.haulmont.addon.grapesjs:grapesjs-web:0.5.3 > org.webjars.npm:github-com-artf-grapesjs-preset-newsletter:0.2.20 > org.webjars.npm:juice:4.3.2 > org.webjars.npm:web-resource-inliner:4.3.4 > org.webjars.npm:request:2.88.2 > org.webjars.npm:mime-types:2.1.35

Possible solution:
 - Declare repository providing the artifact, see the documentation at

Here is the project properties selected:

I have tried changing the repositories but the same.

I am using the latest version of the Platform v 7.x and the studio.

I too have just started having the same error. I see where at least another user has been experiencing same.

Does anyone know what is going on ?

For a quick fix, I edited my build.gradle file and did the following:

  1. Locate the following section:
configure(webModule) {
  1. I then added the following line to the list of dependencies:
  1. Run the ‘Clean’ task and restart application

Mine started to work after doing that


Thank you Robert. It’s working for me too.