Studio throwing error when changing any Project Properties


In the latest version of Studio 6.9.5, which I upgraded to today, seems to throw and error every time I try to click Ok/Apply to any changes I make to the Project Properties. The error thrown from Studio is below.

Is anyone else having this issue?

2018-08-28 19:10:59,243 ERROR [] Exception occured
com.vaadin.server.ServerRpcManager$RpcInvocationException: Unable to invoke method click in com.vaadin.shared.ui.button.ButtonServerRpc
 at com.vaadin.server.ServerRpcManager.applyInvocation(
 at com.vaadin.server.ServerRpcManager.applyInvocation(
 at com.vaadin.server.communication.ServerRpcHandler.handleInvocation(
 at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(
 at com.vaadin.server.communication.ServerRpcHandler.handleRpc(
 at com.vaadin.server.communication.PushHandler$
 at com.vaadin.server.communication.PushHandler.callWithUi(
 at com.vaadin.server.communication.PushHandler.onMessage(
 at com.vaadin.server.communication.PushAtmosphereHandler.onMessage(
 at com.vaadin.server.communication.PushAtmosphereHandler.onRequest(
 at org.atmosphere.cpr.AsynchronousProcessor.action(
 at org.atmosphere.cpr.AsynchronousProcessor.suspended(
 at org.atmosphere.container.Jetty9AsyncSupportWithWebSocket.service(
 at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(
 at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(
 at org.atmosphere.websocket.DefaultWebSocketProcessor$
 at org.atmosphere.util.VoidExecutorService.execute(
 at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(
 at org.atmosphere.websocket.DefaultWebSocketProcessor.invokeWebSocketProtocol(
 at org.atmosphere.container.Jetty9WebSocketHandler.onWebSocketText(
 at org.eclipse.jetty.websocket.common.message.SimpleTextMessage.messageComplete(
 at org.eclipse.jetty.websocket.common.WebSocketSession.incomingFrame(
 at org.eclipse.jetty.websocket.common.extensions.ExtensionStack.incomingFrame(
 at org.eclipse.jetty.websocket.common.Parser.notifyFrame(
 at org.eclipse.jetty.websocket.common.Parser.parse(
 at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
 at org.eclipse.jetty.util.thread.QueuedThreadPool$
Caused by: java.lang.reflect.InvocationTargetException
 at sun.reflect.GeneratedMethodAccessor119.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(
 at java.lang.reflect.Method.invoke(
 at com.vaadin.server.ServerRpcManager.applyInvocation(
 ... 34 more
Caused by: com.vaadin.event.ListenerMethod$MethodException: Invocation of method buttonClick in$3 failed.
 at com.vaadin.event.ListenerMethod.receiveEvent(
 at com.vaadin.event.EventRouter.fireEvent(
 at com.vaadin.event.EventRouter.fireEvent(
 at com.vaadin.server.AbstractClientConnector.fireEvent(
 at com.vaadin.ui.Button.fireClick(
 at com.vaadin.ui.Button$
 ... 38 more
Caused by: java.lang.NullPointerException

Which version have you updated from?
Studio Browser- or SE- edition?
Which OS do you use?

Hi @iskandarov

I’m on OSX and I think I was on Studio 6.9.4. I’m on the electron based standalone edition.

I’ve tried both new and old projects and get the same issue.

I tried reinstalling Studio from scratch but that didn’t help.

Could you please provide studio.log file with described error stacktrace?
Or just the stacktrace of the java.lang.NullPointerException from the bottom of the error message.


Here is the log file you wanted

studio.log (19.3 KB)


Do you use any custom app components in the projects that fail with exception?

Hi @gaslov

Nothing that weird. It currently builds and runs fine I just can’t do anything with the project properties. Here is my build file.

build.gradle (11.2 KB)

Thanks again, build.gradle file was very helpful.

We have found the problem, it will be fixed in the next maintenance Studio release. Here is the issue.

There is a workaround: put ‘declarativecontrollers’ app component dependency before ‘helpsystem’ app component dependency in your build.gradle file.

Hi @gaslov

Many thanks for looking in to this. The workaround has got me going. :grin:

Thanks again for the great support.