Studio - Invalid DB scripts directory name format Exception

Hi,

in the current release of studio (previous versions i did not tried) i got this exception when i try to start the application sever the second time on the same db instance name:
Caused by: java.lang.RuntimeException: Invalid DB scripts directory name format: 50-cuba-example-temporal-reference-data

The full stacktrace you can find in the attached file. You can have a look at the problem with this example project: https://github.com/mariodavid/cuba-example-temporal-reference-data. Can this have something to do with the length of the project name? It can be worked around if in the second time the application should start the db instance name of the hsqldb is changed, but that might not work for everyone :slight_smile:

Perhaps you might want to take a look at it.

Bye,
Mario

invalid-db-scripts-dir.log (10.7K)

1 Like

Hi Mario,

Thank you for reporting the problem.

Due to this change included in the platform 6.3.1, the database update fails if the project name contains dashes.

I’ve just fixed the issue, the fix will be in the platform 6.3.2. Until then, you can build CUBA Gradle plugin with the fix from sources:

  • Clone https://github.com/cuba-platform/cuba-gradle-plugin

  • Checkout release_6_3 branch

  • Kill daemon (if on Windows): gradle --stop

  • Build and install plugin to local Maven repo: gradle assemble install -PbuildVersion=6.3.1

  • Open your project in Studio, edit Project properties, select Advanced > Use local Maven repository

Now the database update should work correctly.

Hi Konstantin,

thanks for the quick fix. I’ll give it a try!