Studio hot deploy of groovy service implementation


it seems that in Studio 2.2.3 hot deployment of services written in groovy does not work. Although in the logs of studio the redeployment occurs, nothing changes.

[19:31:05.058] Hot deploy: modules/core/src/com/company/example/groovyhotredeployservice/service/ProgrammingLanguageServiceBean.groovy -> build/tomcat/conf/app-core

For this to show, i created a “Programming Niceness Evaluator” :D. When changing L11 from the example of the “ProgrammingLanguageServiceBean” (e.g. toggle “language.dynamic” to “!language.dynamic”).
Now i tried the four different stages:

  1. just re-click the button on the screen: nothing happens
  2. re open the screen and click the button: nothing happens
  3. re-login, open the screen and click the button: nothing happens
  4. start & stop tomcat, re-login, open the screen and click the button: the code changes.

It would be cool if you could have a look :slight_smile:

Mario (89.3K)


Hi All,

do you see now when will this implementation be available? It takes a LOT of time to always reload the whole app…


Thank you for your nice project!
Unfortunately, the hot deployment of services does not work indeed. Sources are copied to the conf - folder, but the Middleware could not apply them without restarting.
This behavior does not depend on programming language: services written on Java also require restart for changes to take effect.

Maybe in future hot deployment of services will appear, but it is hard to implement.


Sorry for the previous comment. It was my mistake.
The hot deployment of service implementation on Java works now.
The hot deployment of services on Groovy has not been implemented yet, but we are planning to add it in future.

Hi Rostislav,

that’s great news. Thanks!


State and milestone of the problem you can see in Youtrack. The link to the corresponding Youtrack issue is now on the right.

Cheers Mate! :slight_smile:


Hot deployment of groovy services is available in the platform version 6.4.RC0.

:ticket: See the following issue in our bug tracker: