Studio does not start JDK 8 and 10 installed

Good morning everyone!

I have the same issue on my mac. Cuba is currently running, but the window is not showing up.
JDK 8 and JDK 10 is installed. I loaded JDK 8 before starting Cuba Studio SE but it didn’t helped.
The strange thing is, it worked perfectly 2 days ago.
Currently, I completely removed Java and re-installed it and Cuba Studio also. It didn’t helped either.

Please, does someone have any ideas?

Could you please bring more details?
Did you removed JAVA 10 as described here?
Is there anything in ~/.haulmont/studio/logs ?
Does Browser edition work OK?
Also, try to cd /Applications and open CUBA\ Studio\ SE using Terminal.


Of course!
Yes, I removed it exactly like described.
The browser version works, accept the login page won’t appear.

Here is a snippet of the log file:

2018-09-06 19:34:14.729] [info] Start Studio from /Applications/CUBA Studio, on 30100 port
[2018-09-06 19:34:14.754] [info] Server PID: 7513
[2018-09-06 19:34:14.792] [info] Waiting for the server start…
[2018-09-06 19:34:15.581] [info] Server log: Run Studio headless

[2018-09-06 19:34:15.796] [info] Waiting for the server start…
[2018-09-06 19:34:16.475] [info] Server log: 19:34:16,474 INFO [StudioServerManager] CUBA Studio v.6.9.5 built on 2018-08-22 18:07:20

[2018-09-06 19:34:16.804] [info] Waiting for the server start…
[2018-09-06 19:34:17.126] [info] Server log: 19:34:17,125 INFO [IOUtils] META-INF/services/org.atmosphere.cpr.AtmosphereFramework not found in class loader

[2018-09-06 19:34:17.340] [info] Server log: 19:34:17,340 INFO [IOUtils] META-INF/services/org.atmosphere.cpr.AtmosphereFramework not found in class loader

[2018-09-06 19:34:47.883] [info] Waiting for the server start…
[2018-09-06 19:35:18.889] [info] Waiting for the server start…
[2018-09-06 19:35:49.901] [info] Waiting for the server start…
[2018-09-06 19:36:20.909] [info] Waiting for the server start…

I’ve found something in the localhost.log:

SCHWERWIEGEND [localhost-startStop-1] org.apache.catalina.core.StandardContext.listenerStop Exception sending context destroyed event to listener instance of class [com.haulmont.cuba.core.sys.AppContextLoader]
at com.haulmont.cuba.core.sys.AbstractWebAppContextLoader.contextDestroyed(
at org.apache.catalina.core.StandardContext.listenerStop(
at org.apache.catalina.core.StandardContext.stopInternal(
at org.apache.catalina.util.LifecycleBase.stop(
at org.apache.catalina.util.LifecycleBase.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.startup.HostConfig.deployDirectory(
at org.apache.catalina.startup.HostConfig$
at java.base/java.util.concurrent.Executors$
at java.base/
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/

Probably you have not completely removed JAVA 10.
Which version of Mac OS do you use?
Try to execute /usr/libexec/java_home - it will show which JAVA is the latest in your system.

How have you set JAVA_HOME and PATH environment variables? The problem might be that MacOS GUI does not apply them and uses (the newest)JAVA 10 when you start Studio SE by double click in Applications.
Please try the following:

  1. execute env | grep JAVA, env | grep HOME in Terminal to ensure BASH uses right JDK
  2. cd /Applications
  3. open CUBA\ Studio\

If Studio SE starts OK in this case, try to set JAVA_HOME and PATH in the way GUI accepts them. How to do it correctly depends on the MAC OS version.

Thank you very much for the response. I will try that when this hell of a week is over. :slight_smile:

Edit: I am working on macOS 10.13.6

I removed Java 10 like recommended on the Oracle page. But it didn’t worked.

So I googled a while and found this:
How to remove Java 10
And yes it worked, and Cuba SE starts, like back in the good old days! :grin:

1 Like