[Studio 6.9] app-component.xml is created in the wrong place

another issue with Studio 6.9:

I have a component built with previous Studio version, and if I open it with the latest 6.9 I notice that the Run menu is grayed out.
Studio thinks that the app-component.xml descriptor is missing, but indeed is present and it worked before.
If I click on Add component descriptor, Studio adds an app-component.xml in the src folder of the global module, and not under my.root.package.mycomponent as it should.

Even if I create a dummy app-component.xml in the src folder, and then I install the component in the local maven repo, the component seems broken. When I add a local reference to another project, only the global module jar is deployed to tomcat, and the other ones are missing…

Please give me some feedback ASAP, as I’m stuck on this… thx!


UPDATE: I wasn’t able to fix this, but I resorted to creating the component project from scratch, and now it works… I don’t know if others will be affected by this strange behaviour, but at least a clean project seems to work normally as before.

Hello, @pfurini

It seems that your problem is related to this issue: YouTrack

Hi Paolo,
Which version of the platform is your project based on?
It seems some error occurred when Studio opened the project. So it was not loaded correctly. It happens from time to time when required files are blocked by another process.
The error should be logged (appear in messages on the bottom of Studio window and written to studio.log).
Reopening should solve the problem.

Yeah, probably it’s related to it, but if I recall correctly the metadata.xml was there, but it could be that I messed with some properties or the component descriptor itself…

Thx for your response, but I tried everything, like closing / re-opening Studio, plus killing zombie java processes, without success. Only re-creating the project skeleton from scratch resolved the issue.