Studio 6.4 shows blank screen on Windows

When starting the Cuba Studio 6.4 the server window appears but stays empty. See attached screenshot.

From knowing where the start button appeared in previous versions, I was able to start the server by clicking at the upper right corner. After a little while the server is running and I can access the studio on my local machine through the browser. Everything works ok.

It is however very annoying to have a blank/empty server window.

I already restarted and reinstalled Studio 6.4 but without improvement.



Several users encountered the same problem, but we could not reproduce it.

Could you please answer a couple of questions:

  1. Which version of JDK do you use? Which version of Windows do you use?

  2. How did you installed the JDK? Is it updated from a previous version? Or did you download the JDK installer?

  3. Does the new Studio work if to start it with the -nogui option?

studio.bat -nogui
  1. Does the 6.3 version of Studio work on your system?

Here you are:

  1. JDK: 8.0.1120.15 (Update 112)
    Windows 10 Pro 64-bit

  2. JDK installed through installer some 4 months ago, no updates.

  3. The --nogui option does not work. Nothing happens and after waiting a long while I still cannot access studio through the browser. I examined the bat file and saw that the part that handles command line options is somewhat mixed up (missing newlines). I added them as it seemed logical but it did not help.

  4. It did work up until I installed 6.4. From that moment on 6.3 showed the same problem! I uninstalled everything and reinstalled 6.4 but the problem persists. I now start the server by clicking the upper right corner hoping to hit the button that was there in previous versions. That works.

I did not reinstall 6.3 since I already migrated my project to 6.4 and cannot roll back.

Strange thou that after installing 6.4, the 6.3 didn’t work no more either.

How have you migrated the project to 6.4? With the new version of Studio (which you able to start by clicking the upper right corner)? Or with the RC version of Studio (which was available in January)?

Could you please try to launch Studio with the attached studio.bat? Unzip it and put into the /bin directory of your Studio installation (C:\Program Files (x86)\CUBA Studio 6.4\bin by default), replace existing. (1.9K)

I migrated the projet using the new version of 6.4 - not a RC. I have not installed RC’s at all.

The new studio.bat is no improvement - the behavior is still the same: blank window appears and when blind clicking in the upper right corner the server starts.

I did do a default install by the way (C:\Program Files (x86)\CUBA Studio 6.4). I’m keeping everything as standard as possible.


Sorry that I did not answer so long. And thank you for your test of the custom studio.bat.

We still do not know what is the reason of the problem. But one user reported that the issue disappeared after he had replaced JavaFX libraries (ant-javafx.jar and javafx-mx.jar in the JDK/lib directory). He said that he copied the files from a machine on which Studio works well.

So it seems that installation of a brand-new JDK should solve the problem. Try to remove all Java installations and updates from your system, also remove the corresponding folders (and C:\ProgramData\Oracle\Java too). Then download and install the latest stable build of Java. Do not forget to adjust PATH and JAVA_HOME.

Hi Berend,

Assumably we have found the reason of the problem.

Which video card do you have? NVIDIA?

It was discovered that the latest NVIDIA driver might cause problems with Java applications. The hot-fix video card driver was released but is not available for auto-update yet. So installation of that driver should solve the problem. Could you try it?

Hi Rostislav,

My problems have become bigger regretfully. I do not have NVIDIA so the proposed solution is not applicable to my situation.

I thought to give it a try and update all of the JDK stuff, including removing the ProgramData\Oracle\Java directory. It didn’t help. No difference at all, window stays blank. I even tried OpenJDK but that results in a warning (which I can read) that it is not compatible.

Now even worse, when starting Studio, the start button (which I cannot see but know the location from previous versions) results in a warning dialog. This dialog pops up but doesn’t show what’s actually wrong. Probably I need to reconfigure something but as I can’t see anything, I can’t do it. Is there anything to configure through the registry or whatever?

Current situation: unable to run studio. This is a huge problem now! Any help appreciated .


Could you please share the error dialog? As it is very hard to find the reason by the description.

You have said that you have modified the studio.bat. Do you launch the modified one or the script which goes with Studio installer by default?

Does javaw.exe appear in processes?

Does Studio work well if to launch it with -nogui option? Not –nogui.

Also, try to open CMD and launch studio.bat from there. The path to javaw.exe will be displayed.

This helps to check whether the correct JDK is used (it means PATH and JAVA_HOME are correctly adjusted).
Maybe ProgramData\Oracle\Java is still written to PATH, but you have deleted it.


Well - I found out that the config.xml in my users .haulmont directory contained the configuration which I needed to change and now I’v pointed it to the correct JDK directory.

Although the screen remains blank when starting studio, I can now start the server using the correct spot on the window (upper right corner). At least I can continue my development work…

Current sittuation: still blank window but less of a problem.

Hi Rostislav,

The error dialog remains empty and I have worked around it by modifying the config.xml directly.
The option of -nogui works well. Still when opening ‘normally’ the window remains empty.