SQL Server reserved words

Hello, I’m creating an entity that will be stored in a SQL Server database. one of the entity’s required field is “time”, however, in CUBA Studio, it won’t let me because it says that “Value is a reserved keyword in DBMS”.
However “time” is not a reserved keyword in SQL Server.
Would you know how I can circumvent that? I’m using a library that is expecting a column called “time”.


Hi Francis,
Unfortunately, you will not be able to work with a column called “time” in the current version of Studio. But we will try to improve the handling of reserved words in the future.

Hi Francis,
In the Studio version 2.2 added an ability to use DBMS reserved words as column names.
When the forbidden column name is specified, Studio offers to add it to the list of accepted names. If ‘OK’ is chosen Studio will omit that word in the project. The “DBMS reserved words accepted as column names” is available on the Help > Settings page. There is an ability to remove names from the list.