Set Table Column width in Cuba-studio

I have tried to set my preferred with of some table columns in cuba-studio and by code, but when I deploy the application the column is set to default width. I can set the preferred width in the deployed application in runtime but not in development.
How do I set preferred width of columns in development so that the width is as I have set as default?


I suppose you are confused with our mechanism of user settings. When user changes an order of columns or width of some column or columns visibility in a table CUBA saves this user-specific preferences to the system table SEC_USER_SETTING. If you change width in XML descriptor and a user has tuned table view then options from XML descriptor will be ignored and user settings will be applied.

So, when you test your new width, collapsed or order of columns please check if you have tuned user settings in SEC_USER_SETTING table. If you want to apply new look for all the users then you have to delete user settings with name equals to the screen id you’ve changed from the SEC_USER_SETTING table.

How do we turn off this feature globally or for component specifically?

You can disable user settings for concrete Table using setSettingsEnabled method:


Or you can switch to manual settings saving using cuba.gui.manualScreenSettingsSaving application property in


Save settings action will be available in context menu of main TabSheet.

I see this topic as unanswered, but want to get some info about fixing the column (or whole table) width.
I have a frame, which has vbox inside. this vbox is 100% width. Inside the box i have a table, which is obviously 100% width, and with undefined column widths.
As i enter some big strings in the cells of this table, it starts to move to the right, and a horizontal scroll appears. I set multilineCells="true", but it barely help, and the column width stays the same and doesn’t fit the frame.