Session timeout

I try to parameterize the Session Timeout to 30 seconds. I have reviewed the post and I have tried:

cuba.httpSessionExpirationTimeoutSec = 30
cuba.userSessionExpirationTimeoutSec = 30
cuba.web.uiHeartbeatIntervalSec = -1

But I can’t get it to work.

Any help?


Where do you set the options?

You need to set thi option in

cuba.httpSessionExpirationTimeoutSec = 30

And this option goes to

cuba.userSessionExpirationTimeoutSec = 30

As for cuba.web.uiHeartbeatIntervalSec = -1, it seems there is a bug in the platform. I’ll investigate this and file the issue.

Thanks for the reply. I set both options at

Tried your advice, but It doesn’t work either. I wait for several minutes and the session didn’t expire.

There is a bug with cuba.web.uiHeartbeatIntervalSec application property. We are planning to fix this in the next bugfix version of 6.10 release.

For now, as a workaround you can set the value bigger than cuba.userSessionExpirationTimeoutSec:

cuba.userSessionExpirationTimeoutSec = 60