Server won't start

I’m running into a strange bug. When I build my app and try to start the server (from Studio), everything appears to be fine - no errors in any of the logs. But, the server never starts and the link field remains grayed out. I’ve run into this problem on both Linux and OSX.

What’s going on? Not sure how to debug.


Hi @esamsta14743,

Did you check the app.log and studio.log files?
If there’s nothing there, maybe you have an old server instance process that wasn’t killed that runs obviously on the same port preventing the new server instance to start.
It’s my only guess.

Hello @esamsta14743

Please check that you don’t have any other launched Tomcat instance.

It can be done with ps aux | grep catalina on Linux.


Thanks for the suggestions. There’s no app.log file, just studio.log, and it appears unremarkable. Prior to trying to start the server, there’s no instance of tomcat running, and after I start the server (from studio) there is still no instance of tomcat/catalina.

Weird. Any ideas on how to debug this?


There is app.log. You can even access it in the studio. Check it, you will find something useful there for sure.


Please check for logs in your tomcat instance directory: <app_root>/build/tomcat/logs/.

Have you tried to run tomcat manually? It can be done with script in the bin directory of tomcat.

Okay, mystery solved. The executable flags on and weren’t enabled.

Thanks for all the help.