Saml login redirects not to https

SAML login works fine, but the final response after successful login at the IDP to url https://…/app/saml/SSO leads to an redirect to http://…/app, but i need https://…/app

how can i get the https for the redirect ?

Have you tried setting the Saml.Proxy.enabled and setting proxy.serverUrl web-app-properties settings?


I have set these attributes but after the login at the idp(keycloak) the redirect to the app works with the correct https:// …

but the target app redirects with “HTTP 302 found” to the insecure http …

As a workaround i redirect again to the https:// with the proxy …, but i stuck why the plugin does not use the cuba.addon.saml.proxy.serverUrl also for the last redirect