Running studio on linux

Previously, I was using Studio 6.5.4 on windows. I am now trying to shift development to the server on which the production database will be running. I am using PostgreSQL inside of a TurnKey LAPP install which does not have a desktop environment. I have installed Oracle JDK 8. I have downloaded and extracted the Studio zip file ( I set the JAVA_HOME variable. I can run the studio (in headless mode), start the studio server, and open the Studio web app. I have migrated my files to default studio projects directory. I can open my project just fine. I changed the connection parameters for my postgreSQL server and the connection test is successful. But the issue comes when I try to start the application server, the output in the dialog box says the build is successful but the app itself doesn’t go live on the specified port. I don’t know what the issue could be. I just wanted to see if anyone has some experience running studio in linux. Let mt know if any other information is needed. I’ll also keep this post updated as I also slog through this. Thank you!!!

Update: The sample project works with default HyperSQL settings as well is with my postgreSQL connection. My project does not work with the default HyperSQL conenction.

:start[ant:exec] Result: 1

This is the final line of the build command output. I decided to delete the tomcat folder in my project so it can be rebuilt on the next server restart. It worked. My project now works with my postgreSQL database.

I hope this information helps. I wanted to share my findings as I tried to tackle this so that hopefully others who have the same problem can get some help also.

1 Like

Thank you for posting these answers!