Rich search: Latest version is out there?

As I have moved my project to the lasted 6.9 version, I wanted to use Rich-Search addon. According to the github page, the latest version of the add-on that supports Cuba 6.9 is 1.1.0

However, when I tried to add the app Component in my project, I get the following error.


Any clue?

Hello, @mortozakhan!

Thanks for the notice :grinning:
We fixed it, please try again.

Hi Evgeniy
Thanks for publishing the new version, appreciated.

I want to use exactly what is shown in shown in the short video of the comp i.e. searching for screens.browse. Is there any code example that can be shared?

Just use Quick Start section in README.

Also here is a link to a demo project that may be useful.

Hi Evgeniy
Thanks and of course I have read the readme. And thank you for the link to the demo. However, I didn’t find any difference in my app and the readme instruction or your demo app.

I have tried in my own sample app and it worked perfectly but it is not working in my real project. Now wondering if there is any limit of the number of menu items as the only difference is, my actual project has few hundreds menu items. Any comments?

Fyi, here is my xml of ext-mainwindo

<?xml version="1.0" encoding="UTF-8" standalone="no"?> <window xmlns="" caption="mainMsg://application.caption" class="" xmlns:main="" xmlns:ext="" xmlns:search=""> <dsContext>

<hbox id="titleBar"> <search:richSearch id="search" align="MIDDLE_LEFT" ext:index="3" inputPrompt="msg://search" suggestionsLimit="100"> <search:strategyBean name="search_MainMenuSearchStrategy"/> <search:strategyBean name="search_UsersSearchStrategy"/> </search:richSearch> </hbox>
i have also tried only with <search:strategyBean name=“search_MainMenuSearchStrategy”/>


if there is any limit of the number of menu items

No limits.

  1. Do you see search field on main window after component adding?
  2. Does it find a standard menu items (e.g. Users)?
  3. Does it show “no results found” on search?
  4. Which browser do you use?.

Hi Evgeniy
here is the requested info:

  1. Yes, search field is on main window.
  2. no
  3. When I enter text to search (e.g. user name or menu item), it doesn’t return anything, only a highlighted while row as you see in the image below:

However, when I delete the search field contents, then I get ‘no search result’ message as below:
4. Firefox, Safari, opera - tried all of them, no difference.

Hello, @mortozakhan!

Side menu is not supported by main menu strategy :frowning_face:

But! I added a new RichSearch version - 1.2.0 with side menu support. Please check it. :grinning:
The documentation will be updated soon.

<search:strategyBean name="search_SideMenuSearchStrategy"/>

Hi Thanks. Tried but the Artifact is not available. Can you check?

Please, try again :grinning:

This new version is working. Thank you.

1 Like