Reverting back to a previous ext.cubaVersion

While following a tutorial, I changed my gradle.build file to include ext.cubaVersion = '6.3.4’
When I back up to ext.cubaVersion = ‘6.3.2’ and try to build Gradle, I get
Error:Could not get resource ‘https://repo.cuba-platform.com/content/groups/premium/com/haulmont/reports/reports-global/6.3.2/reports-global-6.3.2.pom’.

It can be a temporary network error. If the problem persists, try to open this URL in web browser, entering the parts of your subscription ID as a user name and password. Please inform us if it doesn’t work.

The problem won’t go away even after deleting the whole project then rebuilding it file by file from a repository. I’ve tried every username-password pair I’ve used (with Cuba-Platform) at that URL, but can’t get in.

What kind of error do you get when opening the URL in browser - a “request timed out” or a basic authentication request that you cannot get through?

Authentication request.

authenticationRequired

Are there any pom files that are changed in the process of altering the ext.cubaVersion? I couldn’t find any, but something has definitely changed…

Ok, I think I got the username and password correct - the Cuba authentication - but then I get this screen:

Access to repo.cuba-platform.com was denied

You don’t have authorization to view this page.
HTTP ERROR 403

Nope. That’s the regular username and password, I think it wants the premium, which I don’t know.

OK, so I got it to work. I deleted everything, uninstalled Cuba Studio and Intellij (just like before) but this time when I reinstalled Intellij I didn’t keep any of the prior settings. It worked. I can run the project again, but it was overly difficult. Please provide a better solution in case this where to happen again to someone else.

Thanks

The Reporting artifacts are located in the premium repo (as shown in the URL) and access to this repo requires special credentials that you get when you have a subscription. So cuba / cuba123 won’t work for this repository. Please find your subscription information and register your Studio instance, or when building from command line, use the credentials as explained here.

The access to a repository is needed only when you don’t have an artifact cached on your computer, so it explains the fact that you ran into problems when switched between platform versions.

Thank you