Repository Error - Can not Start Cuba.platform

Hi,
I can not start the platform. My log file:
Code blocks


2017-01-26 13:58:32,453 ERROR [com.haulmont.studio.server.a] Repository access error
java.io.IOException: Server returned HTTP response code: 401 for URL: https://repo.cuba-platform.com/content/groups/work/com/haulmont/cuba/cuba-global
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
	at com.haulmont.studio.server.c.run(SourceFile:233)
	at java.lang.Thread.run(Unknown Source)
2017-01-26 13:58:33,638 INFO  [org.atmosphere.util.IOUtils] META-INF/services/org.atmosphere.cpr.AtmosphereFramework not found in class loader

I am not connecting behind a proxy. I have all the exceptions for Java and imported the certificates. All these do not help. I can not start.

Thanks in advance.

1 Like

Please check what you have in Studio Server > Repository > Auth. Credentials for our public repo are cuba / cuba123

Yes, credentials are true. And I can login to repository from my browser.

Can you share the whole studio.log?

Please find attached.

studio.log (113.9K)

Unfortunately, there is no useful information in the log except that the error is caused by failed authentication in the repository.

Please switch Logging level in Stusio Server window to DEBUG, start again and attach the log file. Also, make sure there is no hidden spaces in the user name and password in the Auth dialog.

Unfortunately there are no hidden spaces or any other characters in the user name and password in the Auth dialog.

Please find the DEBUG mode log attached.

studio.log (9.0K)

Still nothing unusual in the log. Can you send us your IP on info@cuba-platform.com so weÔÇÖll try to find your requests in the server log?

I have sent. Thanks in advance. The email will come from armagand@geleceginbilgeleri.com.

Unfortunately we cannot say what is wrong from our side.

Attached is a very simple Java program with sources that does exactly what Studio does when it checks the access to the repository. Could you run it on your computer?

repo-access-test.zip (11.0 KB)

Unfortunately same result.


D:\sil\repo-access-test\repo-access-test>run.bat

D:\sil\repo-access-test\repo-access-test>java -cp .\out\production\repo-access-test repo_test.Main
Exception in thread "main" java.io.IOException: Server returned HTTP response code: 401 for URL: https://repo.cuba-platform.com/content/groups/work/com/haulmont/cuba/cuba-global
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
        at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
        at repo_test.Main.main(Main.java:25)

D:\sil\repo-access-test\repo-access-test>

Hi, I have tried it from my notebook at the weekend. Again same result. :frowning:

Hello,

Did you try it from a different network? I can only guess that some router cuts off authorization headersÔÇŽ

Can you also make sure there are no antiviruses or firewalls blocking access for Java programs?

Yes, my notebook uses totally different network.

I am using Windows Defender. I have tried after totally disabling it. But same result.

Do you want to connect my computer with TeamViewer or equivalent and diagnose yourself?

HI, IÔÇÖm experiencing same issue.
I installed Kubuntu 18.04, on a new machine, Oracle Java 8u171 and studio 6.8.5 but when I start CUBA (WEB) and try to import project copied in new machine i get:

cannot access repo.cubaÔÇŽetc.
On terminal i Get this:

Caused by: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
at sun.security.validator.PKIXValidator.(PKIXValidator.java:91)

and searching on google I found some similar cases.

I tried credential via WEB cuba/cuba123 but no success.
It seems connected to local java keystore in 8u711 upgrade which changed some algorithm.

Resources:




https://bugs.java.com/view_bug.do?bug_id=8191486

Any change occurred(repository passwords for example)? previous installation of studio 6.8.4 on old machine Kubuntu 16.04 works perfectly.

Please may someone provide some hints?

ubuntu package:
ca-certificates-java

Thanks in advance,
Fabrizio De Massis

Updated from ubuntu 17.10 to 18.04 and have same issue.

Found this.

I did
sudo rm /etc/ssl/certs/java/cacerts

and
sudo update-ca-certificates --fresh

And started working

1 Like

Thanks Andrea Batazzi, it works also for me.