Reports artifacts in repository


I tried to activate Reports in Cuba 8 but unfortunately send me to Nexus Repository Manager.
It’s mandatory to have an account to Nexus Repo in order to activate Reports?


How can I revert the build?


In order to use Reports 6.10 from Studio 7 you have to setup repository access.

In ~/.gradle/ you have to set your licensing information from key:


Reports are available for free only since 7.0 version of the framework.

I don’t have gradle properties in .gradle


In addition I cannot run the program now:


seems to be a configuration problem in app-core…

I removed appComponent(“com.haulmont.reports:reports-global:$cubaVersion”) for build.gradle.

Ok, just know that in this case reports will not be available in your project.

If I have commercial Cuba license key is the same procedure?

I made a file with upper infos key but is the same result:

Could not GET ‘’. Received status code 401 from server: Unauthorized

Configure build error:
Caused by: org.gradle.api.artifacts.ResolveException: Could not resolve all dependencies for configuration ‘:appComponent’.
With these credential I have the next message:

The credentials seems to go with but I have the same result:
Error: Current project is not a CUBA Platform project. Try resync the project.

Do you have an example to configure nexus sor bintray on linux?
I’ve created an account but I have the next error:



I made an account in Nexus and I’ve created two repositories (in order to use reports feature):


I don’t know how should I select cuba group…and where is Configuration Tab.


What license key should I configure for Cuba premium repository: 111111222222 and abcdefabcdef or my nexus user credentials?



I have a Cuba project (version 6) and when I try to clean configuration files I have this error:

AILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':app-core'.
> Could not resolve all dependencies for configuration ':appComponent'.
   > Could not resolve com.haulmont.reports:reports-global:6.10.4.
     Required by:
         project :
      > Could not resolve com.haulmont.reports:reports-global:6.10.4.
         > Could not get resource ''.
            > java.lang.NullPointerException (no error message)

Please advise.

You did not configure your premium credentials. Please check our docs and use your license key in ~/.gradle/ For example, if your key is 111111222222-abcdefabcdef, then the user name is 111111222222 and the password is abcdefabcdef

If I have commercial Cuba license key is the same procedure

Yes, it is the same.

Where should I find this key?
Is NuGet API key or is another one?

I have a project in Cuba 7 and another one in Cuba 6.
Cuba 6 worked fine but now when I tried to open the project (in Cuba 6) I have this error message.
For Cuba 6 is not necessary to set any premium credentials.

It is your premium license key. If you bought a license then we sent you the key via email.

Now I understood and it’s working. Thank you!

But if I had not a premium license, how should access the reports in Cuba 7?
I know that are free to charge.

I should use this key?
111111222222 and abcdefabcdef

Premium repository is not used for reports 7.0+, all releases available in the main OSS repository.

1 Like