Related attribute not properly shown

Despite intensive research I cannot discover the reason, . I’ve created the relationship in the entity, I created the view and based the screens on the view. The editor screen is showing the picker field, it opens the related entity, choosing the records works, but instead of the attribute value Iám getting the following. “ [detached]”. The browser screen displays the same. Creating a new project with some test entities, works fine. How can I fix this?


Did you define an Instance Name (see the tab in Studio entity designer) for the Positions entity?

Solved. Thanks

In the case above, what was the Instance name defined as? Just select the attribute?

I have the same issue. In my applicationEdit screen applicationRate displays correctly, but in the applicationBrowse screen table, I get of numbers and letters)[detached]%

I tried setting the Instance Name of ApplicationRate by clicking on “rate” -> but it’s not fixing the problem.

We need to look at the ApplicationRate entity source code.


No attachment, try again please.

Oops. My bad.

ApplicationRate.txt (3.6K)

Unfortunately, we cannot reproduce the issue. Your ApplicationRate class and its @NamePattern looks perfectly valid, so rate value should be displayed as an instance name. Try to clean and rebuild the project. If the problem persists, try to create a test project where the issue is reproduced.

I’m unable to replicate the problem in a test project. Is there a work-around to get the correct value to display in the table ?

change from: of numbers and letters)[detached]%

to: 3.5

It’s now displaying as a double! I had to remove the formatter - - from the column.

Thank you for posting the solution!