PSQLException: ERROR: no unpinned buffers available

I am getting the following error message whileI try to edit in one of the many entity editors in the application. While googled, it seems this was a bug in old version of PostgreSQL. Is it still a bug or anything to do with CUBA? unpinned error.txt (58.4 KB)

Thanks in advance for your help.

Hi Mortoza,

As I see in the log the query has 39 JOINs. It seems you need to ease it. Try to optimize the view which is used in the edit-screen datastource.

If the problem persists, increase “shared_buffers” size in postgresql.conf.


Hi Rostislav
Yes indeed those entities are like that, having relations with many others which is required.
I have tried to increase the buffer size but seems not working yet. Here is what I did:

  1. Went to the Jealastic dashboard and opened the file postgresql.conf and increased the memory size, saved and then Postgres restart. No progress. Then restarted the service, no improvement.

Noticed that when I restart, it goes back to the original buffer size of 128K

When I run an sql from the PostgreSQL admin, the status of buffer looks like as below:


Any further suggestions?


I have googled and found this Stack Overflow topic.
Assumably, you should delete #Jelastic autoconfiguration mark in /etc/php.ini
See also this Jelastic documentation.

Resolved the issue by removing the line: #Jelastic autoconfiguration mark, which is located in the line 1 of postgresql.conf file. After that I have changed the shared_buffer size.

1 Like