Problems Starting Cuba Studio 6.4

When I try to start the study it just does not start, I have JAVA_HOME defined, the jdk version is 1.8.0_102. The system simply tries to start and does not start, there is some log that can observe or make it work manually and verify its failure.


In the windows registry this is appearing this:

   C:\Program Files\Java\jdk1.8.0_121\bin\javaw.exe 

Any idea to solve it?

Thank you for reporting. We are investigating the problem.

In the meantime, you should be able to start Studio without its server window:

studio.bat -nogui

Hello Nelson,

Unfortunately, we could not reproduce the problem. But several users report the same problem.

Could you please try the following: 1) uninstall Java and updates from your computer, 2) remove corresponding folders from Program Files, 3) install the latest JDK and adjust JAVA_HOME.

In my assumption, this should solve the problem.

I did it but it did not work

Yes, it works, I have access again

Did you download a new JDK installer? Or did you use some previously downloaded one?

Could you please also try to launch Studio with the attached studio.bat? Unzip it and put into the /bin directory of your Studio installation (C:\Program Files (x86)\CUBA Studio 6.4\bin by default), replace existing. (1.9K)

Rostislav, thank you for your time. I decided to move my Windows machine to openSUSE Linux and everything perfect again, until I have a better performance.

Hello Nelson,

Could you please answer one more question:
Do you have a GeForce video card? Did you use the latest version of NVIDIA driver for Windows?

As was discovered the latest NVIDIA driver might cause problems with Java applications. So downgrading to the previous version or installation of the hot-fix video card driver should solve the problem.

Answering your question, if I have an nvidia 930m video card. Thanks for all the support.

Hi Guys,
Just downloaded cuba platform and had the same problem. I solved it by setting my java home path using / instead of \ as per the screenshot above

so java_home : C:/Program Files/Java/jdk1.8.0_151 instead of C:\Program Files\Java\jdk1.8.0_15