Problem with DB manager


It seems that the DB manager cannot correctly asses the DB schema state.

  1. I deleted the entire database,
  2. Deleted the core module init and update directory
  3. Rerun the DB manager which is generated the new init scripts, and update scripts.
  4. I can create the DB normally with the correct schema.
    5 when I run the app server I allways get a popup that the DB schema is not up to date, so i can rerun the DB manager or let update db in the background.
  5. When I rerun the DB manager it prepares a lot of update scripts, but they are not correct, they creating indexes and constrains which are already exists in the tables, so when I run update db, it fails because the constrains already in place.

What can be the problem?


Hi Sandor,

Please provide more information: database, platform and Studio versions. Also, would be great to see the source code of an entity with the relation that causes generation of existing constraints and indexes.


I attached the global and the core modules.
I use the latest studio and platform (v6.3.1 and v6.3.4), the database backend is a postgresql (PostgreSQL 9.6.1 on x86_64-apple-darwin16.1.0, compiled by Apple LLVM version 8.0.0 (clang-800.0.42.1), 64-bit)
The machine is a retina Macbook Pro with macOS Sierra.
The JDK version is: Oracle SE 1.8.0_112 JDK

I hope you find some clue what is the problem. (186.9K)

The problem is that JDBC driver that ships with Studio does not fully support the newest PostgreSQL 9.6.1. We’ll upgrade the driver in the next Studio release.

Meanwhile, you can download the new driver from and replace existing one in the lib folder of the Studio installation.

Thank you for reporting the issue!

1 Like

:ticket: See the following issue in our bug tracker: