Possible very serious studio bug? "Main menu not found"

While working on the project, I needed to rearrange the main menu a bit, and… it’s not there in the Project window. I’m also noticing in the studio event log:

09:27	Main menu not found

09:27	Main menu not found

09:27	Main menu not found

09:27	Main menu not found

09:27	Main menu not found

09:27	Main menu not found

But the odd thing is, if I go and run the app - the main menu is there as I expect it to be. But it’s not showing in the Project tree so I can’t edit it, and the studio event log is throwing that above error.

I don’t know WHEN this happened; I don’t edit the main menu often…and so I can’t give a reproduce.

But, I do need to know how I can fix it.

I still do not have a reproduce for this problem, but I did fix it. (Though I don’t know why it fixed it.)

While trying to figure it out, I opened the web-app.properties file and noticed all the lines had red “error” lines under them, saying duplicate property. Thinking that a little odd, I closed studio, renamed the file via explorer, re-opened studio, and renamed it back in studio with a right click->rename, then closed and reopened studio and all was fine.

I’ll keep a close watch and see if it happens again and if so… maybe then will have a reproduce.


I got an equivalent error when I tried to update vom 7.1.13 to 7.1.5. After the refresh of the build.gradle file, my project hierachy was not displayed in the “normal” CUBA style. I did not get direct access to views, menus, services, etc. I opend the web-menu.xml and all links to screens are marked “red” - not found.

I did not manage to resolve the bug till now. Downgrading does not work, reloading the project is without effect.

Best regards

One of two recipes usually helps with such problems:

  • Run “Reload all Gradle projects” action from the Gradle tool window located in the right side of the IDE window
  • Invoke from the main menu: File -> Invalidate Caches… -> Invalidate and Restart

Hello, thanks for the answer. The problem was a wrong reference to the graph library within the gradle file. I do not now why this got an problem while I tried to update vom 7.13 -> 7.15. I inspected the warnings within the CUBA log and found corrected them.