org/apache/commons/io/IOUtils not found

I was suggested to upgrade to 6.5.5 for a db issue. But once I upgrade my application to 6.5.5, I got error as below:

... 99 more
Caused by: java.lang.NoClassDefFoundError: org/apache/commons/io/IOUtils
 at CubaPlugin$_addDependenciesFromAppComponentsConfiguration_closure38.doCall(CubaPlugin.groovy:699)
 at com.sun.proxy.$Proxy59.accept(Unknown Source)
 at java_util_function_Consumer$accept$ Source)
 at CubaPlugin.walkJarDependencies(CubaPlugin.groovy:729)
 at CubaPlugin.this$2$walkJarDependencies(CubaPlugin.groovy)
 at CubaPlugin.walkJarDependencies(CubaPlugin.groovy:719)
 at CubaPlugin.this$2$walkJarDependencies(CubaPlugin.groovy)
 at CubaPlugin.addDependenciesFromAppComponentsConfiguration(CubaPlugin.groovy:667)
 at CubaPlugin.this$2$addDependenciesFromAppComponentsConfiguration(CubaPlugin.groovy)
 at CubaPlugin.addDependenciesFromAppComponents(CubaPlugin.groovy:611)
 at CubaPlugin.this$2$addDependenciesFromAppComponents(CubaPlugin.groovy)
 at CubaPlugin.doAfterEvaluateForModuleProject(CubaPlugin.groovy:161)
 at CubaPlugin.this$2$doAfterEvaluateForModuleProject(CubaPlugin.groovy)
 at CubaPlugin$_apply_closure2.doCall(CubaPlugin.groovy:77)
 at org.gradle.listener.ClosureBackedMethodInvocationDispatch.dispatch(
 at org.gradle.listener.ClosureBackedMethodInvocationDispatch.dispatch(
 at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(
 ... 104 more
FAILURE: Build failed with an exception.

After that I try to create an application based on 6.5.5 from CUBA studio, I got the same error.
I have checked CUBA Studio installation folder and I found commons-io-2.4.jar is there and ‘’ is in it.
Once I downgrade CUBA platform to 6.5.4 the error disappeared. How can I solve this problem?

BTW, I have tried to use ‘gradle’ from command line and everything is OK.
BTW again, my Studio version is 6.5.4.

Thanks for your time

As I have read in another topic your project has custom application component. Have you upgraded the version of the platform in the component?
From time to time NoClassDefFoundError occurs by undefined reason and disappears after the system restart.
Try to restart Gradle daemon after the platform update: open Process Explorer and kill all java.exe processes. If it will not help restart the operating system.

Thanks a lot for your suggestion. I will try to upgrade to 6.5.5 later this week again later this week.

The problem is finally solved by downgrading locale GRADLE version to 3.1. But still, I’m wondering how local GRADLE impacted the built-in version of studio.