Ordering of columns in table with includeAll

I created a table in CUBA with includeAll option. I cleaned the SEC_USER_SETTING table, so it’s not related to that.
Basically, my entity’s fields are being shown in a weird order. I’m wondering what the default ordering of the column is: should the columns be shown in the same order as they are written in the entity? Is there perhaps a setting to do that? Let me know, thanks


The order of added columns depends on order of entity attributes returned by io.jmix.core.FetchPlan#getProperties. If you need to place columns in a specific order, then you need to define columns explicitly.


1 Like

All right, thank you Gleb.