onRefresh on Pivot Table

Hi there,
when we attach an event listener to a Pivot table on a web module we will get a strange error.

    transactionPivot.addRefreshListener(new PivotTable.RefreshListener() {
        void onRefresh(PivotTable.RefreshEvent event) {
            progressBar.visible = false

It has to be related to the data somehow, as it works in dev and staging, just on our live database it throws:

java.lang.IllegalStateException: Can’t find method onRefresh with 0 parameters in com.haulmont.charts.web.toolkit.ui.client.pivottable.CubaPivotTableServerRpc
at com.vaadin.server.ServerRpcMethodInvocation.findInvocationMethod(ServerRpcMethodInvocation.java:82)
at com.vaadin.server.ServerRpcMethodInvocation.(ServerRpcMethodInvocation.java:42)
at com.vaadin.server.communication.ServerRpcHandler.parseServerRpcInvocation(ServerRpcHandler.java:604)
at com.vaadin.server.communication.ServerRpcHandler.parseInvocation(ServerRpcHandler.java:546)
at com.vaadin.server.communication.ServerRpcHandler.parseInvocations(ServerRpcHandler.java:512)
at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:343)
at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:274)
at com.vaadin.server.communication.UidlRequestHandler.synchronizedHandleRequest(UidlRequestHandler.java:90)
at com.vaadin.server.SynchronizedRequestHandler.handleRequest(SynchronizedRequestHandler.java:41)
at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1435)
at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:361)

Could you please help me with this issue?


Downgrading to 6.8.4 makes the problem go away…

1 Like

Hi Gabor,
In what version did the problem appear?

Hi Konstantin,

The last correct one is 6.8.4. The problem will appear in every single one, upwards from that.


I have tried to reproduce the problem but Pivot Table works OK. After the platform version changes - too.
The exception seems to show that wrong libraries are left in your Tomcat.
So try to clean the project, dropTomcat, assemble and redeploy the application.


Hi Rostislav,
Sorry for the late reply, I have cleared up the build scripts, Gradle cache on Jenkins machine, deleted the base tomcat docker image, still hasn’t solved the issue. But apparently version 6.8.8 has solved it somehow :slight_smile:

Thanks for you help again!