Migration to 6.8.7 widget set not built any more, neither copied into war


For quite some time I have the below warning on buildwidgetSet in Studio when assembling the project. I seemed to have no effect, so I did not pay attention but it might have an impact though.

Today I migrated from 6.8.5 to 6.8.7 and the widget set was not built any more, neither copied in war file (buildWar). So I had the infamous “resource not found […] AppWidgetSet […]”.

Clean then reassemble did nothing. buildWidgetSet was still claiming UP-TO-DATE. So I finally made a dummy change in AppWidgetSet.xml, and reassembled, it worked.


Not sure if the migration forgot to clean something, or if the below message is involved.


Unfortunately, we cannot reproduce the problem. We will be able to help you if you send us a small sample project along with reproduction scenario that demonstrates the issue.

Hi myatlev. I tried but did not manage to reproduce the issue on a smaller project, if/when I suceed I’ll send it.

Hi Michael,
Build tasks do lots of file operations. Theoretically, the files could be locked(by another program) and the building process fails.
Which OS do you use? On which drive the project is located? Do you use antivirus program?

Hi Rotislav,

I’am on Win10, files are on c:\ and I have an antivirus for which I’ve just set an exclusion of all my dev files.

Seems the buildWidgetSet now works, I guess AV do not like JS files.

Still have the WindowPreferences message though, but as long as build widget set works no sweat