Maps not shown on Server only on localhost

I am not sure where the problem is located but the google map will only be displayed while on localhost and not on server.

I use the following entries in the web-app.properties under modules/web/src

charts.map.freeApiKey = AIzaSyAqqvkvu0BYJI3-hV3dyAX4Ra5CCwGT7qE
charts.map.defaultZoom = 9.0
charts.map.defaultLatitude = 52.540014
charts.map.defaultLongitude = 13.415551

I only generate one side with a standard mapViewer

This key is a server key. I tested a browser and this server key under wordpress and only the server key works.

But both keys don´t work under cuba.

Please help!

Hi Torsten

Currently Cuba uses version of Google Maps V3 API which doesn’t require free key at all (quotas for maps with no free api key are the same as for maps with free api key). So I doubt that you problem is key related.

If your maps work on local machine and not on the server (with the same settings and same version of Cuba) then I would be certain that the problem is on your server side.

Hi Igor,

thanks for the fast reply but there is not a problem with the key because the warning is also on localhost but there the map will be displayed.

Take a look here, I think this is the real problem:
https://vaadin.com/forum#!/thread/3802318

It is a bug in the vaadin MapViewer, but there it is fixed already.

See the attached picture

relevant

Hi Torsten,

we will merge fixes of Vaddin addon and make a maintenance CUBA release this week. Hopefully it will help you with your issues.

@Igor:

I installed the new release 6.26 but still no change.

Is it still the same bug ?

Regards,
Torsten

Hi,

do warnings still appear in the javascript console?

Note that API key property has been renamed, you have to set API key using property charts.map.apiKey now.
You should specify Browser key in there, unless you have paid subscription to Google Maps, in that case you should specify client Id using charts.map.clientId application property.

Perfect, with changing to charts.map.apiKey it works.

Thanks a lot,
Torsten