login screen not reachable if opened from internet

Hi to all,
I have a strange problem.

I’m working on a project and i want to expose tomcat on the port 8080 to let the user test the application from internet.
I have a static ip address so i tried to connect to the application with


the problem is that the browser freezes and doesn’t show the login screen.

I’m sure that tomcat is reachable because:
Under the project dir (~/studio-projects/KGest/deploy/tomcat/webapp) I created a new /test folder in which i added 2 files
1 - index.html = a simple html page that is displayed correctly on the remote host (and locally)
2 - test.jsp = a page that create a connection with the db (postgres) and executes a query. This page is functioning properly on both local and remote host.

I turned off the firewall on the devel pc.
I forwarded ports on the internet fw from 8080 to 8500 to be sure.
Nothing changes.

The thing is that under tomcat/log every logs remain unchanged until i login from the lan. Something is preventing the access on the login page from a remote computer.

I think that i’m missing something with the project configuration

I didn’t make any changes to the default server.xml configuration made by the ide

I checked every log and i didn’t found errors.

have only this warning: “WARNING [http-nio-8080-exec-10] com.vaadin.server.DefaultDeploymentConfiguration.checkProductionMode”

I think this warning is related to the fact that vaadin is in debug mode. I will open a separate thread for this because i can’t get rid of it.

Tomcat version is 8.5.9
Cuba version is 6.5.5

Thank you


Is CUBA Studio reachable via a remote connection (do not forget to check Enable remote connection on Studio Server screen and open 8111 port)?

Could you try to deploy the application to the cloud (for instance Jelastic using Studio deploy screen) to make sure that app settings are OK?

Could you create a new simple project (for instance one of the sample apps available from Studio Samples tab on Welcome screen) and try to connect to it?

Also, you can try to deploy your app on the different machine and check if it will be reachable.

Unfortunately, I cannot reproduce the problem, so it seems that something goes wrong on your PC.


Thank you Gleb,

I tried your suggestions but something is wrong.

Only once I was successful to connect from internet to my application, after that nothing. It is very strange.

I’m setting up a VM with a Tomcat 7, but I have issues with the deployment. I need to open a new thread to solve the deployment problem, than i will continue here.


SOLVED: I installed a new VM with Tomcat 8 to be sure that everything was setting up from scratch.

Since the new VM was not working either, after many hours of diagnostics, the issue was that the MTU of the network interface was not aligned with the mtu of the new internet provider I was switching on.

The result was that only frames lower than the mtu were tranfered. This explains why test pages on the same machine were working.
Since the login interface is far greater than the mtu, that is 1492 bytes for my ISP, the connection “starved”, letting the browser waiting for data while showing the animated circle endlessly.



Glad to hear that you solved your problem and thanks for sharing a solution.