java.lang.IllegalArgumentException: jquery.min.js could not be found

I use cuba 6.9.0, use UberJar to deploy.

Everything is ok, when I use java -jar to run under Macosx. But centos with java version “1.8.0_102” throws the following exception when I open the login window.

    Jun 06, 2018 5:32:54 PM com.vaadin.server.DefaultErrorHandler doDefault
SEVERE:
java.lang.IllegalArgumentException: jquery.min.js could not be found. Make sure you've added the corresponding WebJar and please check for typos.
        at com.haulmont.cuba.web.sys.WebJarResourceUtils.throwNotFoundException(WebJarResourceUtils.java:163)
        at com.haulmont.cuba.web.sys.WebJarResourceUtils.getFullPath(WebJarResourceUtils.java:123)
        at com.haulmont.cuba.web.sys.WebJarResourceUtils.getWebJarPath(WebJarResourceUtils.java:63)
        at com.haulmont.cuba.web.sys.CubaBootstrapListener.getWebJarResource(CubaBootstrapListener.java:69)
        at com.haulmont.cuba.web.sys.CubaBootstrapListener.modifyBootstrapPage(CubaBootstrapListener.java:51)
1 Like

Hi,

Thank you for noticing this problem. We are trying to figure out what is wrong. Do you use uber jar behind HTTP proxy (Nginx / Apache) ?

yes, there’s an nginx front the server online (centos).

Thanks, it is progress https://github.com/cuba-platform/cuba/issues/944
Will fix it soon

Hi @artamonov,
Is this already fixed, because even after upgrading to 6.9.1, I’m still getting the issue.

Hi,

Did you mean updating Studio? We have not yet published platform 6.9.1. Studio and platform have separate release cycles.

Yes, sorry I mean studio 6.9.1

We are going to publish platform 6.9.1. soon. The problem will be fixed if you change platform version in Project Properties to 6.9.1

Ok. Thanks for the info!

Version 6.9.1 has been released!

I confirm, this was fixed in v 6.9.1.
Thanks!