Issue with Uneditable Fields

Dear All,

I am facing a very weird issue related to uneditable fields.

I have built and deployed version 1 of my application on a staging machine with no issues.

After deployment, at some point during development of version 2, I noticed that all fields that are set as editable=“false” in the XML files are now editable, including automatically generated keys and many other fields.

The functionalities related to fields that are enabled/disabled based on a certain condition are all still working. However, the fields that were permanently set as disabled from the screens XML are now all enabled, although the code still shows editable=“false”. It is as if something is overriding the uneditable option of all these fields.

Could you please point me out what could be the reason of this weird issue, noting the following:

  1. Two things I have done after the deployment, which I am not sure if they are related to the issue. I have enable the reports addon and I have upgraded from 6.4.4 to 6.4.5 platform.
  2. If I connect my development machine to the staging database, the issue persists. So it is not a data issue, but a coding issue.

Appreciate your prompt feedback.


Hi Shady,

I’m afraid we cannot say anything without seeing your code. The upgrade on a newer bug-fix version could hardly be the cause because we never change important logic in such releases.

Could you reproduce the issue on a small test project?

Hi Konstantin,

In summary, the issue now is when I set a field to disabled (by unchecking the editable checkbox in studio or by setting editable=“false” in the XML file), the field is always enabled.

It is very hard to share the code as the project is already big.
Would it be possible to schedule a 5-min teamviewer session for example where I could quickly show you the issue?

Appreciate your continuous support.

The issue is fixed after upgrading to platform 6.6

However, I faced a new issue with reporting after the upgrade (Unknown column ‘t1.INPUT_ENTITY_TYPES_IDX’ in 'field list).

I will report this issue in a new thread.