Is MS SQL Server 2014 supported?

One of my clients has a desktop application that stores data in MS SQL Server 2014 and now we are planning to convert this application into a web app using Cuba platform but it seems that MS SQL Server 2014 is not supported by the current version of the platform (6.4.2). Unfortunately, downgrading the existing app into an older version of MS SQL Server is not accepted by the client. So, I would like to ask you if there is any workaround regarding this limitation.


What is the issue that you’re facing when using MS SQL server 2014?
I am using 2014 express edition, it works smoothly.

I have been using CUBA with SQL Server 2016 + SQL Server Azure and they both been working fine for me. Yes, there is the MSSQL 2012 option, but looking at the CUBA framework code, it seems like this options this adds sequence support functionality that is only available in SQL Server 2012 and newer.

I am sure that the CUBA team are better situated to confirm this but I suspect you are thinking that 2012 option means 2012 when it actually means is a version newer than 2012. i.e. 2012, 2014, 2016 and Azure.

The problem had to do with the SQL Server Network Configuration settings. I just enaled TCP/IP protocol and everything is working properly.

Thank you both for your feedback!

Hi guys,

Ian is absolutely correct, by “Microsoft SQL Server 2012” we’ve meant 2012 and newer. If you find any problems with newer versions, please let us know.

I am facing a similar problem
SQL Server 2017, Developer Edition

Database type = Microsoft SQL Server 2012+
jdbc:sqlserver = ‘sql server instance name’ / ‘database name’
— after testing connection I receive the following error
The TCP/IP connection to the host WIN-JUT92L32O69, port 1433 has failed.
Error: “Connection refused: no further information. Verify the connection properties.
Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port.
Make sure that TCP connections to the port are not blocked by a firewall.”.
— please note that I have added necessary rules at the firewall

Is there something wrong in the database definition or something else that I can test or check?

Thank you