IllegalStateException: Unable to parse JSON chart configuration

i have a problem in report chart show.
i created a report about skills with user links. (count users in a skill).
when I create .xlsx template it#s work fine but when I create Chart(pie) this is not functioning and i got error
“IllegalStateException: Unable to parse JSON chart configuration”

Error details

 java.lang.IllegalStateException: Unable to parse JSON chart configuration
	at com.haulmont.charts.web.toolkit.ui.amcharts.CubaAmchartsScene.setJson(
	at com.haulmont.charts.web.gui.components.charts.amcharts.WebCustomChart.setNativeJson(
	at com.haulmont.charts.web.ui.JsonChartController.init(
	at com.haulmont.cuba.gui.xml.layout.loaders.FrameLoader$FrameLoaderInitTask.execute(
	at com.haulmont.cuba.gui.xml.layout.loaders.ComponentLoaderContext$
	at com.haulmont.cuba.gui.xml.layout.loaders.ComponentLoaderContext.executeInitTasks(
	at com.haulmont.cuba.gui.WindowManager.openFrame(
	at com.haulmont.cuba.gui.WindowManager.openFrame(
	at com.haulmont.cuba.gui.components.WindowDelegate.openFrame(
	at com.haulmont.cuba.web.gui.WebWindow.openFrame(
	at com.haulmont.cuba.gui.components.AbstractFrame.openFrame(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at com.haulmont.cuba.gui.xml.DeclarativeAction.actionPerform(
	at com.haulmont.cuba.web.gui.components.WebButton.performAction(
	at com.haulmont.cuba.web.gui.components.WebButton.lambda$new$61446b05$1(

and I attached sample project zip file. without gradle and deploy folder. and report folder is also inside this file
sampleProject - (469.9 KB)

Thank you

sampleProject - (469.9 KB)

Please help me to find the solution for this error.
Thank you


It is really hard to help you without knowing exact reproduction steps. We do not know your data model and you didn’t describe the use case.

Also, please make your question relevant to others, so that more community members could benefit from the response. Avoid specifics of your project where they are not necessary.

In my project I would like to create report chart about Skill and their user count.
when i click “show charts” in report I want show my chart in side report.
For that I create a Chart template in side report with JPQL query

p.skill as "",
count( as "count"
from sampleproject$UserSkillLink e  
join sampleproject$Skill  p on =
join sampleproject$Skillcategory sc on
where = ${skill_skillcategory_name1}
group by, p.skill

<a class=“attachment”

report file
Report for entity User Skill (18.0 KB)

sample project
sampleProject - (469.9 KB)

error I got when I run

Data model

In skill entity I have 2 attributes Skill (string) and skillcategory( association ) type: Skillcategory [sampleproject$Skillcategory]

In Skillcategory entity have Attribute name(string)

In user entity have attributes name(string),position(string) and userskilllink(association) type UserSkillLink [sampleproject$UserSkillLink] and one to many

In userskilllink have attributes skill and user both are association and many to one

I think now you understand what is my problem. I would like to see the chart when i click Show chart in Reports. that’s all I want in this project.

thank you

Sorry, I meant simple steps to reproduce including test data. Finally, I’ve managed to reproduce the error.

And I see that the root cause of the problem is the issue of Show Charts screen. It always uses DEFAULT template to run report, thus it tries to show XLSX binary content as JSON.

We are planning to fix this issue in one of the bug fix versions of 6.10 release.

Thank you for your replay
As you said I change my chart template set to DEFAULT
Now I don’t have any error
but problem is it don’t show chart. i only see blank screen


Chart Name: Pie chart
Band name : count
Title field :
value field: count

if there any mistake I done. Or this error you will fix in next version ?

Thank you so much helping me

Probably, your chart does not contain any data. Check your JPQL query

when I run in XLSX template with this same JPQL query I got my data and I made a graph in side Chart
everything work fine in XLSX output


problem is only happen when I create chart template in side report .