Gradle does not download premium artifacts from command line

Any idea why
gradle buildWar -PpremiumRepoUser=111111222222 -PpremiumRepoPass=abcdefabcdef

gradle assemble -PpremiumRepoUser=111111222222 -PpremiumRepoPass=abcdefabcdef

still does not download premium dependencies (in my case it’s the report)?
it throws:

Received status code 401 from server: Unauthorized

My key is ok. I just registered the studio and built the project from there and it works.

I also created the, still same problem.

Using Platform 6.10.7, Studio 6.10.3 on Linux


Could you please attache your build.gradle file?

build.gradle (5.2 KB)

Sorry, do you pass your key / password to command line?

The first part of your license key before dash is the repository user name, the part after dash is the password. For example, if your key is 111111222222-abcdefabcdef, then the user name is 111111222222 and the password is abcdefabcdef.

Also, you may need to stop Gradle if you change its global Run in command line:

gradlew --stop

Yes, I tried in command line and then I created the file with the credentials but it still didn’t work. And yes, I entered the correct credentials. Now it works but i think just because everything has already been downloaded by the studio.
Next time I will try gradlew --stop

still the same problem even after gradlew --stop
The only thing that works for me is to build with the studio.

Please send us the complete cpmmands that you are using for build in private messages. We will try to reproduce this in a clean environment.