Glashhfish deployment with exploded option

Hi all someone tried deployment on Glassfish 5.0.184?

I did not used single WAR as below:

task buildWar(type: CubaWarBuilding) {
    appHome = './app_home'
    singleWar = false
    includeContextXml = true
    includeJdbcDriver = true

and copied all shared/libs in tomacat in WEB-INF/lib in each application folder (app,app-we,app-portal,app-front).

Than I configured and tested JDBC resources and listeners for a virtual server instance (I followed this “ancient” guide for glassfish 4.0 and cuba 5.6), but concept should be the same…

I Got this error:

Payara 5.0.184

[2019-03-27T18:50:39.346+0000] [Payara 5.184] [INFO] [] [] [tid: _ThreadID=5542 _ThreadName=Thread-44] [timeMillis: 1553712639346] [levelValue: 800] WebModule[/app-core] ServletContext.log():Initializing AtmosphereFramework

[2019-03-27T18:50:39.612+0000] [Payara 5.184] [INFO] [] [] [tid: _ThreadID=5542 _ThreadName=Thread-44] [timeMillis: 1553712639612] [levelValue: 800] WebModule[/app-core] ServletContext.log():No Spring WebApplicationInitializer types detected on classpath

which seems a classloader problems.

By the way I got similar errors in Tomcat on Ubuntu server 18.04 Oracle Java 1.8.191 (and 16.04, where it worked fine with Single WAR deployment, only for app,app-web components).
At the end I deployed local tomcat direcotry in studio and created a sysstemd service which works fine, as described here:

Using Tomcat in Production - CUBA Platform. Developer’s Manual.

I’m uploading some log files for payara and tomcat ubuntu server 18.04.

Thanks in advance,
Fabrizio (8.4 KB)


Exploded shared + webapps deployment is not supported for GlassFish. It is Tomcat only variant. Our tomcat setup has an additional configuration of shared class loader in


You should use either 2 WARs setup or Single WAR with GlassFish.