Extending user Role & Substitution Issues

Dear Sir,
I created an entity with User as a parent class, i added some custom attributes to the entity and also added views. And created an Entity Combined Screen. Everything works fine as expected, but i am facing 2 issues.

  1. I’m unable to create user roles. When i click the create button in roles. It shows No Such Screen
    Screen ‘sec$UserRole.edit’ is not defined. I’ve attached the image for clearificationCapture

  2. When i click the Create button in Substitution User, it open separate screen rather than a popup window. But in the actual implementation of the Administration->User, the substitution User is working as a Popup. I’ve attached the image for better understanding.


Please see how this is implemented in the original UserEditor:

Thank you… I implement in my system…I really appreciate the quick response…

I tried to implement as you said… I added the AddRoleAction class and while executing the following code.


I’m getting an NullPointerException and the full stack is below…

	at com.ipectechnologies.projectnow.web.users.UsersBrowse.init(UsersBrowse.java:74)
	at com.haulmont.cuba.gui.WindowManager.init(WindowManager.java:1242)
	at com.haulmont.cuba.gui.WindowManager.initWrapperFrame(WindowManager.java:1231)
	at com.haulmont.cuba.gui.WindowManager.createWindow(WindowManager.java:581)
	at com.haulmont.cuba.gui.WindowManager.openWindow(WindowManager.java:750)
	at com.haulmont.cuba.web.WebWindowManager.openWindow(WebWindowManager.java:155)
	at com.haulmont.cuba.gui.config.MenuCommand$ScreenCommand.run(MenuCommand.java:181)
	at com.haulmont.cuba.gui.config.MenuCommand.execute(MenuCommand.java:76)
	at com.haulmont.cuba.web.sys.SideMenuBuilder.lambda$createMenuBarCommand$0(SideMenuBuilder.java:175)
	at com.haulmont.cuba.web.gui.components.mainwindow.WebSideMenu$MenuItemImpl.lambda$setCommand$0(WebSideMenu.java:467)
	at com.haulmont.cuba.web.toolkit.ui.CubaSideMenu$1.menuItemTriggered(CubaSideMenu.java:83)

Hello Konstantin I resolved the Problem problem… I solved the issue by correcting the injected variable names…
Now the Substitution user is working as expected in a popup…
But my problem is In the user role and substitution tab… It is coming as Create roles rather than Add Roles… I’ve attached an image for understanding… Please help me resolving this…

I am asking because we can only add the AddSubstitutedAction class only right? not the CreateSubstitutedAction here, isn’t it? Please help me if i was wrong… Thank you…

Unfortunately, I cannot help you without seeing your code. Please create a small sample project with your User entity and the screen.