Error after migrating to 6.5.2

I have updated Studio and set the Platform Project to 6.5.3 and I have started getting errors in Studio like templates not showing when trying to create new screen. I have uninstalled all my versions of Studio (6.4, 6.5) and did a fresh install. Now, when I run the project I get this error:

2017-06-01 12:09:39.971 INFO [http-nio-8080-exec-3/app/anonymous] com.haulmont.cuba.core.sys.MetadataImpl - Metadata initialized in 484ms
2017-06-01 12:09:40.140 ERROR [http-nio-8080-exec-3] com.haulmont.cuba.web.AppUI - Unable to init Template is not foundat com.haulmont.cuba.gui.WindowManager.createWindow( ~[cuba-gui-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.WebWindowManager.createTopLevelWindow( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.App.createTopLevelWindow( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.DefaultApp.connectionStateChanged( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.AbstractConnection.fireConnectionListeners( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.AbstractConnection.internalLogin( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.AbstractConnection.update( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.DefaultConnection.loginAnonymous( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.AppUI.setupUI( ~[cuba-web-6.5.3.jar:6.5.3]
at com.haulmont.cuba.web.AppUI.init( ~[cuba-web-6.5.3.jar:6.5.3]

What do I need to do?
Thank you

i have deleted everything from .gradle , cleaned, restarted and now it works!

Unfortunately, there is an issue with automatic update of Studio to the version 6.5.2. Now it is disabled.
A new Studio release (where the problem is fixed) will be available soon.
To fix the problem locally user can reinstall Studio. (You have found the right approach).
Or revert the update by deleting the ~/.haulmont/studio/update/6.5/02 folder. Applicable on Linux.
Regarding the exception: it occurs when some screen is opened but its XML-descriptor is not found at runtime. Assumably redeployment of the application was enough to solve it. When such problems occur (reporting some sources are missed), execute Run->Undeploy and Run->Deploy in Studio.
Thank you.

Hi Rostislav,
sorry, but I can’t get from your reply if you are suggesting to all users who upgraded to Studio 6.5.2 to revert the installation to a previous version…
Just to know if it’s safe using 6.5.2, or I need to revert to the older version while waiting for a new update.


If you have downloaded and installed Studio 6.5.2 you do not need to revert it. The issue occurs only if Studio was automatically updated to 6.5.2 from one of the previous 6.5.x versions.
I have defined the way to revert the update only for information as we have not described it in the documentation yet.