Error Adding Attributes to Entity in Cuba Studio 6.7.5

When you create a new Entity in Cuba Studio, the first attribute you create is not added to the to the Entity.

Steps to reproduce:

  1. create new Entity
  2. Create new Attribute
  3. Observe that it is not in the Attribute list
  4. Think you made a mistake, attempt to add attribute again.
  5. Error message reported Attribute already exists
  6. Save the Entity and open it back up, attribute is still not there.
  7. Attempt to add attribute again, this time it is ALWAYS successful.

Perhaps it has something to do with the entity not “existing” until it is saved

Another work around is to hit apply before adding your first non-system attribute.


Did you updated your Studio installation or downloaded new version and replaced the old one?

Best regards,

Hello, I performed the update via the link in studio.

I tried uninstalling completely and reinstalling and clearing the browser cache. This only happens if you choose something OTHER than the default UUID entity .

For example, LONG IDENTITY

I have had a couple of colleagues download a fresh version and they experienced the same issue.

Hello, Thomas.

Could you share a small video or something to demonstrate the issue?

I recorded small demo for you and it seems that everything is ok: Dropbox.

Best regards,

Here is a video of the error happening:

Edit: After watching your video I see how it happens. It only happens if you choose your system properties first (as in my video) (creatable, updatable, etc)
If you don’t do that, the attribute will add.

I have reproduced the issue and created a ticket: YouTrack, thank you.

We will fix it soon.

Best regards,

1 Like

Thanks for looking into this!