Error 404 when starting an application on Mac OS 10.14.2


I’m new to CUBA.platform. I installed CUBA Studio v.6.10.1 on my Mac (OS 10.14.2) and follow the steps in the Quick Start Tutorial. But wenn I run and open the “sales-app” on http://localhost:8080/app I get a 404-error. I do the same on my Linux-PC without an error and I could login into the app.

Here is who I start the “sales-app”:

  1. New Project
  2. Project name = sales
  3. Platform version = platform-6.10.5 (default value)
  4. OK
  5. Build → Assemble
  6. Run → Create Database
  7. OK
  8. Run → Deploy
  9. Run → Start application server
  10. Open localhost:8080/app
    => Browser shows error 404

Some tests on the terminal:

Before starting CUBA:

 # netstat -an |grep 8080

After starting CUBA and the application:

#netstat -an |grep 8080
tcp46      0      0  *.8080                 *.*                    LISTEN
tcp4       0      0         TIME_WAIT
tcp4       0      0         TIME_WAIT
tcp4       0      0         TIME_WAIT

Does anyone has the same problem, or an idea?

Thx :slight_smile:


Error 404 in 90% of cases means that tomcat itself has started,
but startup of your application (/app, /app-core) has failed because of some misconfiguration (DB connection problem, local configuration properties etc).

You should look to tomcat logs (catalina.log, localhost.log, app.log) to understand the problem.

Please everyone vote for my feature request Detailed displaying in UI that middleware startup has failed · Issue #225 · cuba-platform/cuba · GitHub
Because I think CUBA should help developers more during coding / debug stage and better indicate application startup problems.



thanks. I solved the problem: My default JVM was 10. After switching the version to 8, everything works fine. :slight_smile: