Embedded entity failure

I is presenting a problem with an embedded entity. Inside the main entity, I have two entities embedded one for address and one for contact.
When I get contact fields simply does not keep any information.

Attached video, where you can see in detail what is happening.

Any help will be greatly appreciated.

Change the file extension, replace zip by mp4

Nelson F.

fail_EmbeddableEntity.zip (1.9M)

Hello Nelson,

it probably happens because instances of embedded entities haven’t been created in your editor and your main entity has null’s there.

Try to initialize them in your main entity editor like this:

    protected Metadata metadata;

    protected void initNewItem(MayMainEntity item) {
1 Like

I do not understand is that for the embedded Address entity that does not happen, just happens to Contact. Now when I make a change without having previously entered data during creation happens the same, does not let modify the registry value simply deleted.

This problem can be considered a bug? or is there a standard solution I do not know, I searched the documentation and can not find a possible solution to it. You may be of the problem by using two kinds embedded in sight?

Someone with such views?

Hi Nelson, could you attach a minimal working project reproducing the issue please?
I wasn’t able to reproduce it myself. I could look into it and figure out what is going on.

Also XML of your screen controller would help.

I must retake this thread, I thought that this problem had already been solved, but now that I’m reviewing the migration of a legancy application, I find the same drawback. Attached project where it’s possible to see that when using the embedded classes within the company entity does not work correctly if I modify the data later and during creation do not fill in the corresponding values such as address, phone, email and others.

Izzy.zip (10.9M)

Please any idea how this can be solved?

Hi Nelson,

Could you please start a separate topic and post your current problem details there?

:ticket: See the following issue in our bug tracker: