Default grouping not working

Hi,
I’m using a groupTable with a nested groupDatasource but choosing an attribute for default grouping doesn’t work. The grouping never takes place when opening the screen. Perhaps worth mentioning that the “group” attribute is an attribute taken from an attached Entity. The view is set up correctly, AFAIK

Hi,

When a user closes a screen, the settings of the screen are saved to DB. And when the user opens the screen next time, the settings are applied. That is why changes in the screen often have no visible effect. effect.

Try to create a new user and open the screen. The default grouping should be applied.

The user settings are stored in the sec$UserSetting table. So you can observe them on the Administration -> Entity Inspector page.

GroupTable has a parameter “settingsEnabled”*. Setting it to *true makes the component not dependent on user settings.

Hi,
I tried both deleting user settings and recreating the db from scratch, but default grouping is still not applied.

I also tried creating a new user. To add further informations, the groupTable is using a nested datasource

Hi,

Thank you for reporting the problem.

For some reason, nested groupDatasoure has the INVALID state after a screen is opened, so that is why default grouping is not applied.

And sorry that I did not notice before that “settingsEnabled” is now available for table components. I have edited my previous comment.

Regards.

:ticket: See the following issue in our bug tracker:

https://youtrack.cuba-platform.com/issue/PL-8813