DbmsType is set to wrong value v7.1.7


I have a working v7.1.7 application using an Oracle database. I need to change it to access a PostgreSQL database instead. I have created the appropriate schema in Postgres and I have changed the Main Database setting in Studio. I have changed the context.xml everywhere I can find it from Oracle to Postgresql driver. However, my logs still say “DbmsType of the main database is set to oracle”. How do I get this to change to Postgresql?

Here’s a screen shot from Studio - you can see that the Main Data Store is Postgresql (an elephant), but the log says “DbmsType of the main database is set to oracle”.


Here is my core/app.properties:


Here is core/context.xml:


This is build.gradle:


I have tried gradle dropTomcat and setupTomcat, just in case something was left. That did not help.

Can anybody suggest what I still need to change?

Finally solved. I don’t know where it got stuck, but after numerous rounds of dropTomcat, clean and setupTomcat it finally cleared out the Oracle setting and connected to Postgres.