DbInitializationException

Starting application gives this error on tomcat logs.
Mysql version: 8.0.11-1debian9

Caused by: com.haulmont.cuba.core.sys.DbInitializationException: Error connecting to database: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY TABLE_TYPE, TABLE_SCHEMA, TABLE_NAME' at line 1
	at com.haulmont.cuba.core.sys.dbupdate.DbUpdaterEngine.dbInitialized(DbUpdaterEngine.java:180) ~[cuba-core-6.8.7.jar:6.8.7]
	at com.haulmont.cuba.core.sys.dbupdate.DbUpdaterImpl.checkDatabaseOnStart(DbUpdaterImpl.java:98) ~[cuba-core-6.8.7.jar:6.8.7]
	... 29 common frames omitted
Caused by: java.sql.SQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY TABLE_TYPE, TABLE_SCHEMA, TABLE_NAME' at line 1
	at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:118) ~[mysql-connector-java.jar:8.0.11]
	at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:95) ~[mysql-connector-java.jar:8.0.11]
	at com.mysql.cj.jdbc.exceptions.SQLExceptionsMapping.translateException(SQLExceptionsMapping.java:122) ~[mysql-connector-java.jar:8.0.11]
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeInternal(ClientPreparedStatement.java:960) ~[mysql-connector-java.jar:8.0.11]
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeQuery(ClientPreparedStatement.java:1019) ~[mysql-connector-java.jar:8.0.11]
	at com.mysql.cj.jdbc.DatabaseMetaDataUsingInfoSchema.executeMetadataQuery(DatabaseMetaDataUsingInfoSchema.java:62) ~[mysql-connector-java.jar:8.0.11]
	at com.mysql.cj.jdbc.DatabaseMetaDataUsingInfoSchema.getTables(DatabaseMetaDataUsingInfoSchema.java:835) ~[mysql-connector-java.jar:8.0.11]
	at org.apache.tomcat.dbcp.dbcp2.DelegatingDatabaseMetaData.getTables(DelegatingDatabaseMetaData.java:645) ~[tomcat-dbcp.jar:8.5.23]
	at org.apache.tomcat.dbcp.dbcp2.DelegatingDatabaseMetaData.getTables(DelegatingDatabaseMetaData.java:645) ~[tomcat-dbcp.jar:8.5.23]
	at com.haulmont.cuba.core.sys.dbupdate.DbUpdaterEngine.dbInitialized(DbUpdaterEngine.java:165) ~[cuba-core-6.8.7.jar:6.8.7]
	... 30 common frames omitted
2018-04-28 17:37:28.358 INFO  [localhost-startStop-1]

Hi,
MySQL server 8 is not supported by the platform and Studio now. You can use MySQL server 5.7
We are planning to support MySQL server 8 in future. See the following tickets:

  1. https://youtrack.cuba-platform.com/issue/STUDIO-4544
  2. https://github.com/cuba-platform/cuba-gradle-plugin/issues/33
  3. https://github.com/cuba-platform/cuba/issues/817

Thank you.

Thanks!
For now I’ve switched successfully to postgres, but I will keep in mind.